Sign In   Register
Pinned Items
Recent Activities
  • How do I remove the blue outline that appears on the checkbox everytime the input is focused (i.e. clicked)?
    1. View Post
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • Thanks Glenn. Silly me, I forgot the preview is run on an environment that does not have my Service. Besides, now I know the preview is run on Client side only so I will surely need to use Form.addPreviewDDSData() to add the stub to act as my Service.

    All working now. Thanks again.
    1. View Comment
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • I am trying to use DynamicData.call() in my Form. There is an existing working Service deployed in Transact Manager (Test mode enabled). I added a Dynamic Data Button in the Form to experiment to see if I can retrieve data from the Service.

    I...
    I am trying to use DynamicData.call() in my Form. There is an existing working Service deployed in Transact Manager (Test mode enabled). I added a Dynamic Data Button in the Form to experiment to see if I can retrieve data from the Service.

    I am running the Form in preview and I keep getting the error message "Cannot invoke DynamicData.call() in preview without adding preview data" when the call is invoked. The error is thrown from the Promise. I realise that the error message is internal as the call did not make it out to the online Service because the same error appears even when I gave it a rubbish Service name.

    The DynamicData.call() works without issue If I deploy the Form to Transact Manager.

    Any help is appreciated.
    More
    1. View Post
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • Hi Mark,
    Thank you for the solution. It works (the underscore at the end of the ID is the missing link for me)

    And as for my model structure of:
    <applicant>
    <repeatingFields>
    <individual>
    <name>John</name>
    <age>33</age>
    </individual>
    ...
    Hi Mark,
    Thank you for the solution. It works (the underscore at the end of the ID is the missing link for me)

    And as for my model structure of:
    <applicant>
    <repeatingFields>
    <individual>
    <name>John</name>
    <age>33</age>
    </individual>
    </repeatingFields>
    <repeatingFields>
    <individual>
    <name>Peter</name>
    <age>44</age>
    </individual>
    </repeatingFields>
    </applicant>

    NOTE that I also wrap a block around my "userName" and "userAge" fields and named the ID = "Individual" (to match the resultant XML structure. I did this before I started the following steps.

    I then entered the ID ("applicant_repeatingFields_") on the 'Repeat' properties inside the 'Repeating Block Template'.
    Then went to the "userName" field, click on the "Integration" tab and change the "XML Name" = "name". I then see the auto filled XML path.
    Then did the same to the "userAge" field (make XML name = "age")
    I also checked that I ticked the 'include in Submission Data' in all related paths (like Individual, name, age)

    After I did the above, and looking at the "Model" tab:
    I noticed a new "applicant ..." (lowercase) entity is created together with the sub-entities (e.g. repeatingFields, individial, name, age). There is also a symbol ("arrowed three quarter circle") at the right of <applicant><repeatingFields>
    So, the original imported "Applicant" entities are not affected.

    Everything is now in the right place and the expected XML is generated. Thanks again.
    More
    1. View Comment
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • I have a Repeat Block Template in the Form with the below fields inside the Repeated Content:

    textfield: userName (id)
    textfield: userAge (id)

     

    How do I map the above to the properties in the Model (already created) below?

    <applicant>
       ...

    I have a Repeat Block Template in the Form with the below fields inside the Repeated Content:

    textfield: userName (id)
    textfield: userAge (id)

     

    How do I map the above to the properties in the Model (already created) below?

    <applicant>
        <repeatingFields>
            <individual>
                name   <--- property (it has a circle on the left in the Form editor)
                age      <--- property (it has a circle on the left in the Form editor)
            </individual>
        </repeatingFields>
    </applicant>

     

    And the expected outcome in the submitted xml is:
    (I have trouble achieving this)

    <applicant>
        <repeatingFields>
            <individual>
                <name>John</name>
                <age>33</age>
            </individual>
        </repeatingFields>
        <repeatingFields>
            <individual>
                <name>Peter</name>
                <age>44</age>
          </individual>

        </repeatingFields>
    </applicant>

     

    I have tried mapping the fields (userName, userAge) to the Model's name and age (e.g. select field userName, then double click name on the Model). But only the last repeat (Peter, 44) appeared and is inside the <TrackingCode> (which is not what I want)

    If I use Repeat instead of Repeat Block Template, it still only returns the last repeat (Peter,44), however, it is in the proper structure (ie. <applicant> ...)

    Thoughts

    • I believe the model's <repeatingFields> structure together with <name> and <age> shall also be made known to Maestro in some way to identify it as a repeat block maker in order to build the desired XML data for submission. How do I achieve this?
    More
    1. View Post
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • Alan Lee unlocked the badge Newbie
    Newbie
    Being part of a community. To unlock this badge, you need to register on this site.
    0
    0
    0
    0
    0
    0
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
  • Alan Lee joined the group, Journey Platform
    Post is under moderation
    Stream item published successfully. Item will now be visible on your stream.
There are no activities here yet
Unable to load tooltip content.

Not a member?

Register to ask a question and access to more content.

Join now

Looking for something else?

You can request access to:

  • Courses
  • Full Release Notes
  • Product Downloads
  • SDK

Request access